Before entering this site you need to make sure you have the latest version of Shockwave installed on you computer. This site will work successfully with Netscape 4.6 and above or Internet Explorer 4.5 and above for the Mac or PC.